Self-hosted API and Chrome/Edge compatibility

25 November 2025 (Edge affected from 10 December 2025): Following the latest Chrome/Edge update, compatibility issues have been identified affecting use of Chrome or Edge with the Self-Hosted API. The root cause is the implementation of stricter network security policies in Chrome and Edge browsers, which prevent properly calling the Self-Hosted API, due to visuals being rendered in an IFrame.

Impact
  • The accoPLANNING visual embedded in Power BI Service fails to communicate with the self-hosted API when accessed via Chrome/Edge.

Root Cause
  • New policy in Chrome and Edge browsers enforce enhanced restrictions on requests to private IP addresses, requiring explicit permission, which Power BI does not pass down to their IFrames for visuals. Resulting in blocked API calls

Solutions

We always recommend that all customers verify either approach with their internal security responsibility instance, as IT security should be taken seriously in all environments.
Looking ahead, the recommended long-term solution will be as described below. We will update the documentation to reflect this.

Recommended Solution

For customers using the Self-Hosted API, the recommended approach is clear - host the API on a public IP address or domain.
This is necessary because the network security policy in Chrome and Edge browsers block traffic to private IP addresses. By hosting the API on a public endpoint, you ensure compatibility and avoid disruptions caused by these restrictions.

Alternative Workaround

As a short-term workaround, user can disable this policy for a short period. While it can theoretically reduce browser security, this setting was previously not enabled by default in Chrome and Edge browser and therefore did not pose an issue. This makes it reasonable to use this temporary workaround until the long-term solution is in place.

Steps to disable Local Network Access Checks in Google Chrome and Microsoft Edge, per user:

  1. Navigate to the "Local Network Access Checks" setting
    In new window/tab, navigate to the relevant setting.
    Chrome: chrome://flags/#local-network-access-check
    Edge: edge://flags/#local-network-access-check

  2. Change the Setting
    On the right-hand side, open the drop-down menu and select Disable.

  3. Restart browser
    After making this change, restart your browser to apply the new setting.

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Prior Issues

1-2 February 2026: A license error occurred on Tuesday afternoon (2 February 2026) as well as on Monday morning. The error was caused by a brief connection glitch between AppSource and our license API. The issue lasted only a very short time and resolved itself without any action required.

Based on this, we will be monitoring the situation more closely going forward. A recent change to the API is currently being rolled back, which we expect will resolve the issue permanently.

Please feel free to reach out if you have any further questions.
For urgent matters, you can also contact us at support@accobat.com, which is monitored continuously.

11-12 January 2026: A License API issue was identified that may have affected the solution on 11 January 2026. The issue was resolved shortly after it was reported.

11 January 2026: The accoPLANNING Professional edition (v1.0.83.5) was deployed to AppSource. When using cell comments, the existing comment history is applied to the transaction together with the new comment. Please refer to the release log for available workarounds. (https://kb.accotool.com/kb/guide/en/1-0-83-5-accoplanning-wwDQFfVypG/Steps/4851995)